Forums
**** Issue with the 1.2.8 Update **** - Printable Version

+- Forums (http://chimerasw.com/starbaseorion/forums)
+-- Forum: Starbase Orion (/forumdisplay.php?fid=3)
+--- Forum: The Galactic Council (/forumdisplay.php?fid=5)
+--- Thread: **** Issue with the 1.2.8 Update **** (/showthread.php?tid=2955)



**** Issue with the 1.2.8 Update **** - rocco - 05-28-2017 01:11 AM

Greetings Emperors.

The update to 1.2.8 did not go as planned. Somehow I submitted an older beta build, which got approved, and then released to you all. The plan to fix this swampy mess is two fold:

1. I will rebuild and resubmit the correct version of Starbase Orion today.

2. I will spend some time looking to see if there is a short fix which can be done to allow y'all to continue playing

In the event that #2 fails, then we will have to wait until the new build passes Apple review again.

My most sincere apologies.

Update #1

After cross referencing the build which actually got submitted, it was a very early build in beta. As such, trying to shoehorn it to work while waiting for the re-review will just leave everyone confused, as it was midway through changes, bug fixes, and implementations. So the correct course of action will be to leave the multiplayer server disabled until the new version has passed review.

Update #2

v1.2.9 (aka the correct build of v1.2.8) has been submitted to Apple review. The server has been updated to v1.2.9, and the submission has been set to automatically release when Apple has cleared it.

Update #3

I have requested an expedited review for v.1.2.9 from Apple. Finger's crossed.

Update #4

Apple has granted our expedited request and v1.2.9 should now be available on the AppStore. Thank you, Apple!


RE: **** Issue with the 1.2.8 Update **** - miljush - 05-28-2017 01:46 AM

If you can try to make it works on older ios versions too, I'm playing on ios7 and it seems that your new update works only on ios8>, thanks✌️


RE: **** Issue with the 1.2.8 Update **** - rocco - 05-28-2017 01:50 AM

(05-28-2017 01:46 AM)miljush Wrote:  If you can try to make it works on older ios versions too, I'm playing on ios7 and it seems that your new update works only on ios8>, thanks✌️

Yes; this wrong build didn't support older OSs. The correct build should.

Cheers.


RE: **** Issue with the 1.2.8 Update **** - Davabled - 05-28-2017 04:00 AM

Thanks for keeping us posted


RE: **** Issue with the 1.2.8 Update **** - ArlyB - 05-28-2017 05:01 AM

Thanks for the swift action, Rocco.


RE: **** Issue with the 1.2.8 Update **** - jared71 - 05-28-2017 06:54 AM

I guess that means we can't play an of our existing multiplayer games until the patch. Hope not too many turns skipped but will be the same for all. Just shows how much I love the game. Please post here to let us know any updates.


RE: **** Issue with the 1.2.8 Update **** - rocco - 05-28-2017 07:14 AM

(05-28-2017 06:54 AM)jared71 Wrote:  I guess that means we can't play an of our existing multiplayer games until the patch.

This is correct; i explored several options to allow playing while Apple reviews the correct version, but unfortunately the version which got uploaded would just make a mess things.


RE: **** Issue with the 1.2.8 Update **** - rocco - 05-28-2017 08:46 AM

v1.2.9 has passed review and is propagating through the App Store.