Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Division of labor bug still at large in 1.0.4
10-19-2011, 03:52 PM (This post was last modified: 10-19-2011 03:57 PM by mindloss.)
Post: #1
Bug Division of labor bug still at large in 1.0.4
I took a few days off from SO, but here I am again. Played for just a little while today with the new version, and very pleased to see a lot of the fixes have made their way in. Also appreciate the sorting in Empire view. The Empire screen is mostly where I 'live' during the game, so the more information that's on there, the better (IMHO). Still wish there was a way to tell if one of your colonized planets was Rich/HeavyGrav/whatever short of navigating all the way to it and hitting the little button at the top within the planet screen. Still having sound issues, but you're apparently well aware of that. (I started with sound off, and everything was nice and quiet until the first time I selected a planet and got the fold-in screens with the animated planet surface. After that, it was in and out, but that effect definitely triggers it, so maybe look that routine over?)

But, onto...

Major bug:

I mentioned this before, but wasn't very clear about it. If it's cosmetic, it's a bad bug. If it's not cosmetic, it's a serious game breaker.

Occasionally (read: fairly reliably, happens every game) a planet will give me shifting values for things depending on the order in which I shuffle my workers around. For example, if I have two units of pop on said planet, and have both on prod, it might show six gears. Then I move them to research and see 11 beakers. Then if I move them back to prod, one at a time, I'll get, say, nine gears. And then moving back to my science, I'll get a different science value.

Bottom line is that on some planets, I appear to get much higher production rates when I move all my guys to science and then move them one by one back to production. I haven't tested whether the values it's giving me are actually true -- but they are persistent, and show up in the empire screen as well (that is, the affected number of turns it will take - often the difference will be as large as 30 turns if I've lined them up one way, 21 or so the other. Same number of workers assigned to each field, just the order in which I place them and source from which I grab them differs.)

Sorry, that was a mouthful. Anyway, looks like that's still bugged. I did grab a savegame this time if you want to see it, although I'm not sure how to get it to you. Which reminds me, is there any info screen in-game that shows what version you're running? I wanted to make sure I wasn't playing an out of date version...

HOWEVER, things are looking much tighter aside from that and the music! And just think... once you get all the kinks worked out, then it's time to get down and dirty with the actual game balance... :-D


Itsy bitsy cosmetic detail: you're not supposed to know the star names (so it seems) until you visit them, but when you have a ship en route to an unknown star, the name is displayed if you go to Military view. But I don't care about that at all. Just reportin'. Smile


EDIT

Forgot to say that I see you fixed the trait listing for custom races in Foreign view. Very handy feature, thanks. Smile (Still says Isather race, and saves game as Isather stardate whatever... guess that's just tossed in since Isather's the first player? Not a big deal.)
Find all posts by this user
Quote this message in a reply
10-19-2011, 05:02 PM
Post: #2
RE: Division of labor bug still at large in 1.0.4
Or, here, this is better than my stumbling through an explanation:

http://imgur.com/a/DTBZ6

I'm hoping this is self-explanatory. Only the outermost one guy is moved at a time. In the empire screen, note the bottom row, note the turns. Planet characteristics and player traits included for reference.
Find all posts by this user
Quote this message in a reply
10-19-2011, 10:16 PM
Post: #3
RE: Division of labor bug still at large in 1.0.4
Great, thanks! Added to the whipping post.
Find all posts by this user
Quote this message in a reply
10-19-2011, 10:27 PM (This post was last modified: 10-19-2011 10:47 PM by thebardofblasphemy.)
Post: #4
RE: Division of labor bug still at large in 1.0.4
(10-19-2011 03:52 PM)mindloss Wrote:  Still wish there was a way to tell if one of your colonized planets was Rich/HeavyGrav/whatever short of navigating all the way to it and hitting the little button at the top within the planet screen.

One way around this is the "Galaxy view" - it gives the essential stats of all planets. I use this view to decide which planets should be better for industrial etc.
EDIT - You can sort according to mineral content etc (just found out how!)

Sorry - this post is off topic, but you started it Tongue
Find all posts by this user
Quote this message in a reply
10-22-2011, 12:16 PM (This post was last modified: 10-22-2011 12:16 PM by rocco.)
Post: #5
RE: Division of labor bug still at large in 1.0.4
Mindloss:

I think I figured out how this could happen, and I believe the necessary fix was already made in 1.0.4.b3.

If you could let me know if this reproduces on a new game under v1.0.4.b3 ( it cannot be an old game ), please let me know!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread:

Contact Us | Starbase Orion | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication